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Being Aware of
Content Aware
] Advanced Photoshop Techniques Made Easy
Nick Melidonis M.Photog. discusses
how to more usefully use Photoshop’s
Content Aware tools.

A

lthough Content Aware is not new in
Photoshop, the latest Content Aware
tools in Photoshop CS6 are nothing
short of amazing.
Mind you, they still don’t work in every
situation and I have found myself doing
some clean-up work, despite my best
efforts after using them. Nevertheless,
the alternative methods of using complex
selections, painstaking cloning and
trying to match patterns, textures and
colours in the areas affected, have meant

that most photographers are delighted with
the results they obtain with these new
‘miracle’ tools.
Whenever I have demonstrated the
content aware tools in my workshops, I
always get a lot of “Ooohs” and “Aaahhs” when
people see how simple it can be.

Content Aware
So what exactly is Content Aware Fill? Very
simply, it is an excellent tool for removing
content in an image that is not needed and

The Content Aware Tools and the Mode and
Adaptation options.

replacing the ‘hole’ with the appropriate
pixels of what would have been left.
Classic examples are when you want to
remove a lamp post or fire hydrant; power
lines that cut across a building and the sky;
grass that cuts across the outline of wildlife
such as birds or animals; scratches and tear
marks from old photos, or any unwanted
portions of an image. In earlier versions of
Photoshop, if you wanted to remove a lamp
post, you would probably have used the
Clone Stamp tool to clone small sections
of footpath, bushes and trees, brickwork
and other areas, and then carefully applied
The Content Aware Healing Brush Tool set to
the ‘Content Aware’ option can work wonders in
removing unwanted objects. In this image taken
in the mountain village of Arachova in Greece,
electrical wires were cutting across the Church
Tower and its tile roof. Using as small a brush as I
could with the image at 100%, I carefully run the
Healing brush along the wires and Photoshop
replaced the wires with sampled pixels of the
background. The pattern of the roof tiles and
the edge of the Church were retained quite well,
a task that would have been painstaking with
the old clone tool. As always when using the
Content Aware Tools, a little experimentation
and some clean-up work may be necessary.
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them section by section to the area you
wanted to remove. The outcome you sought
was to replace or cover up what was there
with what would have been there if these
offending objects didn’t exist.
The Content Aware tools use what Adobe
calls ‘imaging intelligence’ to reduce or
eliminate labour-intensive retouching. Once
you’ve selected and deleted the unwanted
object, the tool analyses the surrounding
pixels to determine the best match for
colours, textures, and patterns to use as fill
material. Then it automatically fills in the area
where the object was, matching light, tone,
noise and texture – magic indeed and all with
unprecedented speed.

Spot Healing Content Aware
The Spot Healing Tool has been around for
a while, but it now has ‘content aware’ as an
option to select. This tool has many uses.
For example, you can use it to get rid of
blemishes and other facial imperfections in
a portrait and it can analyse and replace the
blemishes with the correct skin colour and
pores of the skin.
A suggested technique is to create a
new empty layer and call it ‘Retouching’, then
select ‘sample all layers’ and now click and
dab the face to remove blemishes. If you
continue in this way, the face will appear
almost perfect, but may look a little ‘plastic’
like a mannequin. For a more realistic result,
reduce the opacity of the retouching layer to
put back a hint of the blemishes and so make
the face ‘human’ again.
This technique can also be used to get rid
of power lines, cables, drain pipes and overly
bright objects that can catch the eye. Applied
properly, the results are quick and effective.
Of course, the Spot Healing Brush using
content aware can also be used to remove
sensor dust and other imperfections in an
image, and replace them with a blended
background that looks very natural.
For photographers who enjoy shooting
wildlife, the Healing Brush content aware
tool is a lifesaver. Animals often blend in
with the grass and foliage around them and
quite often some of that grass protrudes
into the image of the animal. Try as we might,
the chances of getting a clean shot of the
animal without the grass can be almost
impossible.
The Healing Brush tool again can work
miracles with just a simple swipe over the
offending grass. I find that the smaller the
brush size (you will need to work with an
image at 100% or more) prevents unwanted

On a boat trip in Sabah, we came across a fisherman casting his nets in the river. I quickly captured
this image with a Canon 5D Mk III and a 100-400mm lens. When I started to process the image
in Lightroom, I noticed the stick coming out of the water (marked in red). I thought I would try
the Content Aware Fill Tool and selected the stick using the Lasso Tool. I then used Edit>Fill and
chose the ‘Content Aware’ option under ‘use’. As you can see, Content Aware replaced the stick and
matched the background with the net very well. [This can now also be done in Lightroom 5 using
the Spot Removal brush.]

leftovers of the image when Photoshop tries
to sample around the selected area.

Content Aware Fill
Larger areas such as bigger drainpipes and
lamp posts can be removed with the Content
Aware Fill tools.
To use Content Aware Fill, make a
selection with the lasso tool around the
area you want to replace and then select
Edit>Fill and choose ‘Content Aware’ in the
‘use’ options drop down box. Click OK and let
Photoshop’s algorithms do the work.
If the object can easily be selected and
there is enough of the image around the
object for Photoshop to look at, the process
is easy and very successful. If not, the result

might not be perfect and there may be some
cleaning up to do.
This technique should be used with larger
objects that the Spot Healing Brush may
struggle with. For example, if I had two yachts
in a photograph and wanted to remove one
so the client can have just their own yacht
in the picture; the process would be easy if a
clean selection of the other yacht could be
made.
This technique can also work well if
you wanted to remove a rock or a piece of
building material from a lawn; simply select
the object to be removed and let Content
Aware fill in the background. Another
example is to replace broken tiles on a roof
and match the pattern of the good tiles to
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My Canon EOS 5D Mk III captured heron with a 100-400 mm lens, but the bird is too centrally positioned due to the focusing point being set to the
middle. I would have preferred the heron to be closer to the right hand edge of the frame. I could have cropped the image, but I thought I would try the
new Content Aware Tools. I wanted to get rid of the piece of log at the bottom right of the image and, as two sides of the log were right on the edge of
the frame, I knew that Content Aware Fill would be difficult. I chose the new Patch Tool, with ‘Content Aware’ and since there was sufficient space around
the log for Photoshop to ‘see’, I chose ‘Loose’ as my Adaptation option. I then dragged the selection to a section of the green background on the left
of the image and the result was a perfect removal of the log. Next I chose the new Content Aware Move Tool with ‘Loose’ as the Adaptation option.
I dragged the selection to the right of the image and again, Photoshop produced a flawless result and filled the ‘hole’ left behind with the appropriate
background.

replace the damaged ones; once a long
and laborious process in earlier versions of
Photoshop, now it is quick and easy.

Content Aware Patch Tool
When objects are right on the edge of an
image, Content Aware Fill can be a problem
as the sampling technique may leave
artefacts or remnants of the image behind.
Sometimes you can’t select an image with

enough surrounding it for Photoshop to look
at, and again, the Content Aware Fill method
will leave bits of image behind.
For the situations described above,
CS6 has now refined the Patch Tool so it
can use the magic of Content Aware as well.
This tool is found with the other Content
Aware Tools in the box containing the
Healing Brush Tool and the new Content
Aware Move Tool.

The Content Aware Move Tool has an ‘Extend’ mode as well as a ‘Move’ mode. This mode is very
good when you want to extend or stretch a piece of an image and let Photoshop’s algorithms fill in
the required pixels. In this photograph of the columns at Cape Sounion in Greece, I selected the
area which I wanted to extend upwards to lengthen the columns, while leaving everything else in
the same proportion. I chose ‘Very Loose’ as the Adaptation and it was the best result from the
other Adaptation options.
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The Patch Tool with the Content Aware
Fill option fills the gap where selections or
the Healing Brush won’t work. Adobe calls
this exciting new option, ‘user driven content
aware fill’, that is, you make a selection
using the new Patch Tool, then you drag the
selection to where you want to sample from
and let Photoshop’s ‘magic’ fill in what is left
after the object is removed. Again, the results
are not always perfect and you may need to
experiment a little to obtain a satisfactory
result.
One of the choices you will have to make
when this patch tool is selected is to choose
what ‘Adaptation’ to use when you make the
Patch Tool selection. The ‘Adaptation’ box is
found in the tool options at the top left of the
tools bar and you have a choice from ‘Very
Strict’ to ‘Very Loose’.
‘Very Strict’ is normally chosen when
there isn’t a lot of room to blend the edges
of the object and there are other things very
close to the object. ‘Very Loose’ is normally
chosen when there is plenty of space around
the object and Photoshop has plenty of
information to blend the object with the new
background.
So how do you choose between Very
Strict, Strict, Medium, Loose and Very Loose?
It’s a case of making an educated guess
according to how much is around the object,
then ‘suck it and see’. The results can be very
different from “What the…” to an acceptable
result. Even though a few minutes can be
spent playing with these adaptations, the
alternative cloning techniques we used to
use from the old days of Photoshop should
not even be considered.

Content Aware Move Tool
Another amazing new Content Aware tool
introduced in CS6 is the Move Tool. Of all
the new tools in CS6, I found this one to be
the most exciting. Before CS6, if we wanted
to select an object and move it to another
place within an image, this used to involve
complex selections, masking, compositing
and so on.
Once a Move Tool selection is made
around the object to be moved (and this
can be loosely selected rather than an
exact and complex selection) and moved
to the new position, Photoshop then looks
at the neighbouring pixels and blends the
object in the new location. Photoshop’s
algorithms look at the surrounding pixels
and patterns surrounding the ‘hole’ left
behind and matches them. When you first
see the result, I’m sure, like me, you will be
gobsmacked.
As before, it doesn’t produce a perfect
result every time and I found that by varying
the area around my loose selection of the
object to be moved produced varying results.
However, by persevering I managed a very
good outcome on most occasions.

As with the Patch Tool described above,
you are given the same choices for the
‘Adaptations’ (Very Strict to Very Loose) and
choosing the right adaptation will produce
the required result.
In the tool options of the Content
Aware Move Tool, you also have a choice
of Modes of either ‘Move’ or ‘Extend’. If you
choose ‘Extend’ then another interesting
variation of this useful tool allows you to
choose a building and ‘Extend’ it higher or
lower and Photoshop will fill in the patterns
etc. to match the extension. You can even
select a corrugated iron roof on a veranda
and extend it out further from a building. It
really is an incredible tool. As before, your

right choice of Adaptation will produce the
best result.
When making a selection, you can try
using the ‘Quick Selection’ tool for a more
precise selection and see what results
you get. A variation of this method is to
use the Quick Selection Tool, then use
Select>Modify>Expand by around seven
pixels, leaving little around the object so CS6
can have a better chance to blend the object
with the new background.
If you have graduated to CS6, then these
amazing new Content Aware Tools will make
a big difference in time-saving enhancement
of images with some very good results that
will amaze you.
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